Deductions Navigator: Data Loading Issues
Incident Report for SupplyPike
Postmortem

Postmortem Review of January 9th, 2020 Deductions Navigator Incident

On Thursday, January 9th, beginning at approximately 12:30 PM Central time, SupplyPike Deductions Navigator users began to experience issues loading Deductions and Order data in the app. The loading issues were due to a database failure that was caused by a spike in large database queries that were not properly handled. The incident resulted initially in intermittent issues loading data and then progressed where many end users experienced a full outage.

To resolve the issue, our engineers were able to quickly scale up memory. This remedied the loading issues and allowed users to access data at approximately 2:35 PM Central time. In addition, the SupplyPike team will be taking several steps to optimize queries that will prevent a similar incident from occurring in the future.

If there are any questions, our Customer Success team is available by reaching out to support@supplypike.com or by using or in-app chat tool.

Posted Jan 10, 2020 - 10:30 CST

Resolved
This incident has been resolved and all data is now loading successfully. If you have any questions, please contact us at support@supplypike.com
Posted Jan 09, 2020 - 15:00 CST
Monitoring
Our engineers have implemented a fix for this issue and we are continuing to monitor the results. Add data is now loading successfully. If you have any questions, please contact us at support@supplypike.com
Posted Jan 09, 2020 - 14:51 CST
Identified
Our engineers have identified the issue and a fix is currently being implemented and tested.
Posted Jan 09, 2020 - 14:25 CST
Update
2:00PM Update: Deductions Navigator is currently experiencing problems loading data. Our engineers are continuing to investigate this issue and we will continue to provide updates as more information is available.
Posted Jan 09, 2020 - 14:06 CST
Investigating
We are currently investigating an issue that is intermittently causing data in SupplyPike Deductions Navigator to not load properly. Our engineers are working to resolve the issue as quickly as possible and we will provide period updates until the issue is resolved. In the meantime, if you have any questions, please email us at support@supplypike.com.
Posted Jan 09, 2020 - 12:48 CST
This incident affected: SupplyPike Deductions Navigator.