Deductions Navigator Incident 6/15/21
Incident Report for SupplyPike
Resolved
This incident has been resolved and all dispute data from Direct Commerce has been updated. If you have any questions, please send us a chat or email us at support@supplypike.com.
Posted Jun 18, 2021 - 09:04 CDT
Monitoring
Direct Commerce dispute status updates were delayed again last night, but will be running throughout the day today.

If you have any questions, please send us a chat or email support@supplypike.com
Posted Jun 17, 2021 - 09:14 CDT
Update
We are continuing to work on a resolution for this issue and are making good progress. We will keep you posted with additional updates as they are available.

If you have any questions, please send us a chat or email support@supplypike.com
Posted Jun 16, 2021 - 17:12 CDT
Identified
Dispute data from Direct Commerce was unable to be updated last night. Our engineering team is aware of the issue and is working on a resolution. We will let you know as soon as the data is updated. If you have any questions, please send us a chat or email support@supplypike.com
Posted Jun 16, 2021 - 10:04 CDT
This incident affected: SupplyPike Deductions Navigator.