Deductions Navigator Incident 6/3/2020
Incident Report for SupplyPike
Resolved
This incident is now resolved and SupplyPike Deductions Navigator is fully operational. If you have any questions, please email our support team at support@supplypike.com.
Posted Jun 03, 2020 - 20:49 CDT
Investigating
Our engineers are currently investigating an issue that is causing degraded performance in SupplyPike Deductions Navigator. We are working to resolve the issue as quickly as possible and we will provide periodic updates until the issue is resolved. In the meantime, if you have any questions, please email us at support@supplypike.com.
Posted Jun 03, 2020 - 16:16 CDT
This incident affected: SupplyPike Deductions Navigator.